
Colors And Fonts
There are several colors and fonts which you can customize in Easytext.
These options can be set from the 'Options,Preferences' selection in the menu or 

most of them can be set individually from other menu options or from the Toolbar.
To change the colors in the 'Preferences. ' dialog, click on the colored panel next to 

the color you are changing. Some of the settings allow for custom colors also.

See Also:

Formatting RichText



Easytext Features

                       Welcome to the Easytext Program.  
This program contains    a number of very useful Features some of which you have 

probably used before and some you may have not.
Below is a list of some of the features incorporated in the program with a short 

description of each. 
For more information on a particular topic see the Help Contents or the Help Index.

       Allows for Multiple Users:   
In the 'Options' section you may add as many 
User Names as you wish.
Each user can customize Easytext    to their own
 preferences with over 35 customizable options.

       Each User Has His/Her Own:  
Favorite Folders
'Save To' List
Most Recent Files List
Format Options Etc.

       Multiple Editors:  
You may choose to open files in a single editor or
 open them up each in it's own editor. Each editor 
is separately customizable.
Tabbed editors eliminate the burden of multiple 
windows.

       Open Files As You Left Them  
Easytext has the ability to restart exactly as you 
shut it down.
Will    bring up the last file you were working on and 
even place the cursor where you left it.

       Plain Text or Rich Text:  
When opening a "new' document, you can select 
whether to open it as Plaintext or Richtext.    This 
saves system resources.
Files can be saved in either format. Warns before 
format change.

       Customizable Folders and MRU lists:  
Add folders to a list of Favorites    list to quickly open folders that you 

use the 
most.
Recent File list can be disabled
You also choose how many files to retain in the 
'Recent File' list.

       Save-O-Matic :  
Tool for automatically saving files as you work. 
You can set the Save Intervaland choose whether



 to save to the original file or to a temporary file.
Turn it on or off with the click of a button.

       Scroll-O-Matic:  
Feature for 'Hands Off' scrolling of the editor 
window.    You set the Scroll Speed.
Works in all four directions. Can be disabled.

       ToolBars - Status Bar - Ruler - ToolTips:  
Two(2) separate Toolbars keep most operations 
a button click away.
Ruler option available for working with Richtext 
documents.
Status Bar at bottom of window shows Username
, Editor State, Current Row and Column, 
WordWrap and User Customizable Date and 
Time.Useful Tool Hints.
All options can be either shown or hid.

       File Registration and File Filters:  
You choose which files, if any, to associate with the
 program.( double clicking on that type file 
launches the Easytext program). You can also set 
up the File Filters for the 'Open File Dialog' box.
(ie: 'Text Files', 'All Files' etc.).

       Run Other Programs  
Set up a list of other useful programs that you use
 a lot.
Programs can be run from the click of a button.

       Colors and Fonts:  
You set the colors for the Editor windows, Ruler, 
ToolTips, Window Font, Tab Font and Spell 
Checker Window. You also choose the font for the
Editor window Tabs.

There are many more features which you can customize to suit your individual needs.
See the 'Options' menu item in the Easytext program for more details.
Once in the Preferences dialog, selecting 'Help' will display help for the page you are 

working on.

     



Editor Windows
       Open Files in Separate Editors  

Setting this option allows each file that is opened 
 have it's own window. Each window can in turn 
have it's own settings.
You can open as many editors as your system 
resources allow.
Each editor will have a tab that can be clicked to 
bring that window to the top.

       
     
       Automatic WordWrap Feature  

This allows you to select whether files that are
 opened in Easytext are automatically wrapped to 
the Editor window when opened.

       Date/Time Format  
Here you can select how to insert the date and/or 
time when clicking on the date in the status bar at 
the bottom of the window. Inserting the date
and time can also be accomplished from the 
menu bar under 'Text, Insert' 
This setting only pertains to inserting the date by 
clicking the status bar.

     
       See Also:  

Colors and Fonts
Editing Procedures
Formatting RichText



Folder Options
By selecting 'Add To Favorites' from the Easytext menu, you can add or remove 

folders
 from this list.

These options allows quick and easy access to the folders you use the most.
You will be presented with a dialog box where you can select the folders that    you 

wish to add to the list. After each folder selection, you will need to hit the Add button in 
order for it to be added.

To remove a folder, select the folder from the list and hit the
'Remove' button.

       See Also:  

Opening and Closing Files
Saving Files

            



General Preferences
       Allow Multiple Users  

This option allows for more than one User to set 
up their options in Easytext.

See Also: 
Specifying New Users

       Confirm Before Changing Settings  
Checking this box will cause Easytext to prompt
you before changing any User settings.
This will give you a chance to 'Cancel' if you
decide to.

     
       Open Program With Last User  

This will cause the program to start up with
the last User's settings. This includes any
open files, window settings etc.
If this option is not selected, the program will
open in the Default state. That is, it will use
the default settings for StartUp.

See Also: 
Specifying New Users

     
       Visual  

Removing a check by any of these Features 
will cause the item to be hidden from view in the
Easytext window.

     
       Recent File Record  

Removing this checkmark will disable the
Recent File list in Easytext. The program will
not keep track of the recently used files if
this box is not checked.

Note: Recent files can also be cleared from the menu
under 'Options'.

     
       On Program Exit  

When you close the program, Easytext carries out
procedures before closing the window.
Some of these are customizable.
If you would like to close all the files you are
working on then place a check next to the
'Close All Open Files' label.
Likewise, to clear the Recent File list on exit
place a check next to the corresponding label.

Note: This option only clears the recent files list. 
                          It does not remove the files from the Open Files list.





Opening And Closing
There are various methods for opening files in Easytext.
If you wish to open a New file, select 'New' from the menu

or hit the 'New' button. You will be asked whether to open the
new file as Plaintext or Richtext. This determines whether
the RichText capabilities are enabled.
By selecting 'Open' from the menu or hitting the 'Open' button
you will be presented with the Open Dialog box where you can
select the file to open. Choosing which file type to display
when in the dialog is determined by the File Filters options
in Easytext.

These settings include Five(5) of the more common ones.
You may remove from or add to this list by selecting 'Options,
Preferences' from the menu and going to the page labeled
'Files/Filters'. For more information on this see Setting Filters.

You may also open files from the Recent File list by selecting
'Open Recent' from the File Menu or hitting the Recent button.
This will present you with a list of recently used files if the
Recent Files option is enabled. 

See:    General Preferences

You can keep a list of Favorite Folders ( see: Folder Options)
from where you can quickly open folders that you use most.

Easytext features 'Drag and Drop' capabilities also for
ease in opening files.

Note:
                          When you open a file in Easytext, the file is placed in a   
RichText editor only if it is a Richtext file.
             Otherwise, it is opened in a PlainText editor. This disables the  
Richtext features of the Editor. If you wish to use RichText
capabilities on a Plaintext file, you will have to Save the File As
a Richtext file first. 

To close an open file, select the file by clicking the
appropriate tab and hitting the Close button ( Red X) or select
Close from the File Menu.

Don't confuse the Close item with the Exit item.
When you exit the program, all files will be removed from

the Open Files list if you have that option selected. Otherwise,
The files will be re-opened the next time you start Easytext.

When you close a file out, you will be prompted to save any changes or name the file 
if you have not already done so.

See Also:
Saving Files





Registering Files

              See Also:  
Setting File Filters

Note:
       This procedure will write to your System Registry.
Although no problems should be encountered registering
files to open in Easytext, if Easytext is Deleted or Un-Installed,
the registration entries made will not be removed.

To register a file type to open in Easytext, place a
check next to the appropriate Extension in the Preferences
Dialog. This can be accessed through the 'Options' menu item.

If the required File Extension is not shown, you may add it by entering the file 
extension ( ie: txt, rtf, ) in the 'New Type' box
and hitting the button next to it. 
Note: Don't enter the period ('.') in the extension.

You may register as many extensions as you like before
closing the window. No changes are made until you select 'OK'
in the Preferences Dialog. You will then be prompted to verify
the changes if the 'Confirm Before Change' option is enabled.

After that, those File Types will start the Easytext program when you open them.



Saving
To save a file either select 'Save' or 'Save As' from the File Menu or hit the 'Save' 

button. If the file is 'Untitled' you will be presented with a 'Save' dialog in which to enter a 
name.

If the file you are working on is RichText, the Save dialog
will open by default to the Type RTF file. Or if the file is a Text
file, the default Extension will be TXT. You can change these
as necessary.

You may also choose to have Easytext automatically save your files as you work. See 
below for more information.

       See Also:  
Save-O-Matic



Setting File Filters

              See Also:  
Registering Files

File Filters are basically filters that filter out certain types of files.
When you use a File Open or Save dialog, the combo-

box    listing 'Files of Type' is such a device.
In Easytext however, you can customize these filters to

suit your individual needs.
These options can be accessed by selecting 'Options,

Preferences' from the 'Options' menu.
Lets say for example you worked a lot on files with a

'.pas' extension but you never worked on files with a '.rtf' extension.
You could choose to add the .pas extension to the list of filters
and remove the .rtf extension.. This is just an example.

To remove an extension, select it in the Current list
and hit the 'Remove' button. 

To add a new type, enter a description in the box labeled
'Description' ( A description would be something like 'Textfile'
or 'Logfile') and then enter the three letter extension in the box
provided. Then just hit the 'Add' button. It will be added to the
list of filters.

In the event that you would like to reset the filters to the
Easytext default filters (the ones that came in the program),
hit the 'Restore' button and all will be as it was when you installed
the program.

       See Also:  
Opening And Closing Files
Saving Files



Specifying New Users
At any time after the Easytext program is installed, you may add or remove User 

Names from the User List. To do this just select 'Options, Add/Remove User' from the Menu 
Bar.

You will be presented with a Dialog box in which you can add as many new Users as 
you wish.

You may change Users at any time while the program is running. To do this, select 
'Users' from the menu and choose the User Name from the list. The previous User will be 
prompted to save any work before changing to a new User.

 When selecting 'Options, Preferences' from the menu. The Options Dialog box will 
reflect the User's name that is the current User. Any changes made to the program options 
will

pertain to the current User only.    Each user has their own settings which are 
independant of    any other user.

When removing users from the list, you can not remove a User name if that user is 
the current User. If there is only one User listed and you wish to remove that name, you will

either have to add another User    name or select 'Restore Defaults' from the menu 
under 'Users'.

Upon removing a user from the list, that user's initialization file is deleted.

See Also:

General Preferences
Editor Window Options
Colors And Fonts
Folder Options
Registering Files
Setting File Filters



Adding To Objects List
Sometimes, you might find yourself 

constantly searching for the same graphics
object to insert into a file or letter. Or you may
type the same block of    text in every file you
open.

Fortunately, Easytext allows you to
save objects and or text that you use frequently
 into a menu that is easily accessible.

The Easytext program comes with a
few objects already in this list. You can access the
list by selecting 'Insert, From Custom in the menu.
Any objects that are in the list are shown as
'Names that you assign to the objects when
you create them. ( ie: smiley for a 'SmileyFace or
MyPicture for a bitmap etc.). Just select the object
and it will be inserted at the cursor position in the
current active document.

To Add to this List:
Just type the text and/or insert objects

as desired in the Easytext editor window.
Highlight the selected text with the mouse
and choose "Customize Selection" from
the menu. You will be asked to enter a 
name for the selection. This is the name
as it will appear in the Menu.

It is best to name the selections with
names that describe what the object is.
This will make it easier to remember what
each one is.

For example, if you have a block of text
that you use as a header for all text files,
You could select the text and after choosing
"Customize Selection" from the menu, you
could name this "Header".
Then "Header" will be listed in the menu
under "Insert", "Objects" and by selecting
it, the text and/or objects will be inserted
at the cursor position in the active window.



External Programs
Adding or Removing:

You can add or remove programs from the External Program list by selecting 'Options, Add To 
Externals' from
the menu.
To add a program, enter the full path and filename 

for the program or hit the 'Browse' button and search for it
that way. The filter for the Browse dialog box is set to show
.EXE files only. If you are looking for a file with another
extension, you will have to select All Files from the 'Files of
Type' box.

After locating the program you wish to add, you will need to hit the 'Add'(>>) button to add it to the
list.

To remove a file from the list, simply select the file in the Current list and hit the 'Remove'(<<) 
button.

Running:
After you have added programs to the 'External Program' list, you can run the programs by 
selecting

'Run' from the menu and selecting the program you wish to run.

Note:
You can not add the same program more than once to the list. If you try to do so, on rare 
occasions it will appear as though the program was added again.

However the program will show up only once on the menu.

See Also:
Folder Options
Specifying New Users



Inserting Graphics
You can insert pictures, sounds etc. into

your projects either by pasting them from 
another program or by selecting    'Insert', Object'
or    'Insert Custom'      from the menu.
For more information on adding objects to your
list of favorite objects, please see:
Adding to Favorite Objects List in this help file.

If you select Insert New Object, you wil
be presented with    a dialog in which you can
select the type of object you wish to insert.
You may choose to insert an object from 
another file or you can choose to insert a 
new object.

You can also select whether to insert
the object as the original or as an Icon, in
which case the object will look like the objects
parent program. ( ie: A paint object will show
up as a Paint program Icon.).

If you choose to insert from file, you will
see a file dialog in wjich you can pick the file
to insert.

Also, if you choose to insert    from file, you
will be given the option of inserting the object
'AS IS' or inserting it as a link.
It should be noted that if you insert an object
as a link, the original object, whever it is on
your system, must stay intact and unmoved.
Otherwise, the Easytext file will not be able to
locate it when necessary.

If you choose to insert a new object,
the program associated with that object will
be launched to enable you to edit the object.
( A Bitmap object will start the Paint program)

Regardless of which type of object you 
insert, you can double click on the object to
launch the objects program for editing purposes.
Or you can Right Click on the object to bring
up a menu of other associated actions.

To remove an object, simply select the
object with the mouse and hit 'Delete' on the
keyboard.



Page Setup

See Also: Printing

            Each time you start the Easytext program,
            the page margins are automatically set to 
            the default value. That is :

Top :          1.25 inches,
Bottom: 1 inch,
Left:              1 inch,
Right:        .75 inch.

If you need to change this before printing,
select 'Page Setup' from the 'File Menu'.
You will see a dialog box in which you can
change the page Margins to whatever you wish.
At the top you can see a page that show about
what your page will look like printed.
After you have set the margins, you may then
select print to begin the print procedure.
(See    Printing ).



Printing
See Also: Page Setup

       Printing in Easytext is fairly automatic.
To begin the print operation, select 'Print' from
the file menu or hit the 'Print Button' on the toolbar.

You will be presented with a print dialog in
which you can select printer, number of copies,
and setup the printer if needed.
The dialog will open up with the default printer
listed as the printer. In most cases, you will not
need to change this.
Also , if needed, you can set the printer options
by selecting the properties button next to the 
printer name. Any changes you make to the
printer will be made for the Easytext program 
only.

If you desire more than one copy of the
project , you can then select the copies desired
 in the 'Number of Copies' edit box.

After you have made any selections desired,
just hit the 'OK' button and your document will
be printed.

see also : Page Setup.



Basic Editing
The editing operations can be carried out from the

Edit menu in the Easytext window or by 'Right-Mouse Clicking' in
the editor window.

Basic editing consists of entering , cutting , copying ,pasting , and  deleting text in 
and out of a text window.
These operations can be carried out from either the'Edit' menu
or the button bar.

Cutting text will remove it from the editor and place it in
the Window's Clipboard.

Copying text places it in the Clipboard but does not remove it from the text.
You select the text you want to cut or copy by placing the cursor at the start of the 

text in question and, while holding the
mouse button down, drag the mouse to the end of the text.
You may also select all of the text in the editor by choosing
'Select All' from the Edit menu.

Pasting simply places the contents of the Clipboard into
the editor at the cursor position.

It should be noted that the Paste features are enabled only
if the Clipboard contains Text.

In the Edit menu there is also a menu item labeled'Delete'.
This deletes the selected text without placing it in the Clipboard.

To 'Undo' the last edit operation you performed, select 'Undo' from the Edit menu.

See Also:
Formatting RichText
Inserting Date And Time



Contents



Formatting Richtext
All of the editing functions listed in the section titled

'Basic Editing' pertain to editing RichText also.
However, RichText allows some options not found in Plaintext
documents.

You can format the text any way you like. That is, you can make any or all of the text 
any color, size, font style etc. that
you prefer. This is opposed to plaintext in which all of the text assumes the same attributes.
Select the text you would like to format and then choose the
Font, Color, Size etc. that you prefer. 

Easytext detects whether the text is in Richtext format.
Using this information, it enables and disables certain options
in the program.

Inserting Bullets is accomplished by hitting the 'Bullet'
button or selecting 'Insert Bullet' from the Text Menu.
A 'Bullet' will be placed at the start of the line.

To set the Alignment of selected text, hit one of the 'Alignment' buttons or select 'Text
, Align' from the menu.



Inserting Date And Time
You can insert either the Date, the Time or the Date and

Time. This is accomplished by selecting 'Insert' from the Text
menu and choosing the format you prefer.

You may also click the Date in the Status bar at the
bottom of the window to insert the formatted Date and/or Time.
Your choice will inserted at the cursor position.

You may also choose which format to use when inserting
Date and/or Time.

Select 'Options , Preferences' from the menu and go to the
Editor tab. There you will see a section labeled 'Date/Time Format.
Here there are several different formats you can choose from.
Just pick the one you like from the list.
Then when you insert the date it will be inserted in this format.

See Also:
Editing Text
Formatting RichText 



Registering Easytext
Thank you for your interest in 'Easytext'. The registration
fee is to help cover the cost involved in writing the program.
It also serves to bring you the very best possible software
through developer support.

        Below you will find the options for registering 'Easytext'.

You may also Register Online by clicking the "Register" 
button on the EasyWare Homepage at : 
http://www.nefcom.net/users/d3tech/

The registration form for ordering can be found at the bottom
of this file and in the file named    'Form.txt' in the
folder in which you installed Easytext. It can also be found
in the Easytext Help file which accompanies this program.
Just open one of these files and select 'print'.
        Or, if you prefer, you can write me a short letter to let
me know what you think of the program. Consumer feedback really
does produce better software.
        Upon receiving your registration fee, the registration number
will be sent to you either via E-mail or Postal or both. Make sure
you specify which on the registration form. Additional copies of
Easytext may also be ordered.
        Any questions or comments may be addressed to:

                                                Email : d3tech@nefcom.net
                                                or                    JStan1@netscape.net

                                                Postal:    Jim Stanford
                                                                                P O Box 4
                                                                                Macclenny, FL 32063

        Thank You again for your continued support. I hope you find the
program useful.

                                                                                Sincerely,
                                                                                Jim Stanford

----------------------------------------------------------------------------
                                                    EASYTEXT    REGISTRATION

Register Online by clicking the "Register" button on the EasyWare
Homepage at :    http://www.nefcom.net/users/d3tech/

                                  The cost to register Easytext is                                      $    20.00      

        Each additional copy = $5.00 x    _____ copies = $_______
        (REGISTERED COPIES)



                                                                                                                                                                  Total =    
$_______

        Please mail Registration Number and\or extra copies to:
        (If ordering extra copies, please be sure to specify a
        Postal address)
        E-MAIL    _______________________________________________________

        POSTAL_______________________________________________________

                                    _______________________________________________________

                                    _______________________________________________________

        Make checks payable to: Jim Stanford
                                                                                                                P O Box 4
                                                                                                                Macclenny, FL 32063



Reporting A Problem
If you experience any problems, have any suggestions

or comments, or would like to see an improvement in upcoming
versions of Easytext, please feel free to contact us in one
using one of the methods listed below.

Remember, better programs happen through User
Feedback. If you don't like the program please, by all means
let us know.

However, if you find it useful, please don't forget to 
REGISTER.

For more information on registering Easytext please
click    HERE.

We can be contacted at:

E-Mail
d3tech@nefcom.net

                                    or                  JStan1@netscape.net

Post Office
Jim Stanford
P.O. Box 4
Macclenny,FL 32063

Phone
(904) 259-8121  or
(904) 259-5073



Save-O-Matic

See Also :
Scroll-O-Matic
Checking Spelling

This feature allows Easytext to save your work while you work. By selecting 'Save-O-
Matic' from the menu or hitting the
Save-O-Matic button, all of your open files will be saved at the
interval you specify. 

There are a few options you can specify    for
this feature.

Select 'Options , Preferences' from the menu and go to the Tools page. There you will 
see an option labeled 'Run Save-O-Matic on Startup'. Checking this will start the 
Save-O-Matic feature every time you start Easytext.

The next option is 'Save Only To Temp File'.
This causes Easytext to create a Temporary file to save
your work in instead of saving it to the original file.
Sometimes you might not be ready to save a file but you would still
like to have a BackUp going in case of Power failures etc.
This option will do just that.

Note: THESE TEMPORARY FILES ARE DELETED DURING    NORMAL PROGRAM EXIT.
On a normal 'Program Exit', you will still be prompted to save your
work. DO IT. These Temp files are only used during the program
to guard against unwanted program shutdown. If this were to
happen, you can retrieve the file by locating it in the 'Temp'folder where you installed 
Easytext.

You will also see an option to set the 'Save Interval'.
This determines how often Easytext saves your work. Set this
interval to save as often as you like.



Scroll-O-Matic

See Also:
Save-O-Matic
Spell Checker

This feature allows for 'Hands Off' scrolling of those really
long text files. Simply select the Direction for the scroll with the
'Scroll Direction' button and then select the 'Scroll Speed' with the 'Speed' button.

These are the blue icons at the right side of the second
ToolBar.

You can elect to hide this feature by disabling it in the
Preferences dialog on the Tools Page. It will also be hidden
if you elect to hide the second ToolBar.



Spell Checking

See Also:
Save-O-Matic
Scroll-O-Matic

Easytext has a    nice Spell Checking feature incorporated
into it. It can be accessed from the Tools menu or by hitting
the 'Spell' button.

There are a couple of features you can set in the
Easytext Preferences dialog . These are Window Color and whether to save the Spelling 
Window position on Exit.

Most of the options of the Spell Checking feature can
be set from the 'Options' button in the Spell Checker.

For more information, see 'Visual Speller Help'




